Page 1 of 1

Vegas/Premiere Problem Using Xvid as External Codec (FIX)

Posted: Wed Jun 05, 2013 2:06 pm
by GameTipsAndMore Blog
Hey Bandicammers, just wanted to share a problem I encountered and the fix I found for it - just in case anyone else runs into the same problem. :idea:

It occurs when importing an Xvid-codec recorded video into Sony Vegas or Adobe Premiere. Some people may experience crazy-coloured 'trails' that look like some sort of 'corruption' when the video is imported into Vegas (but it plays fine in other media players such as Windows Media Player and VLC). *This only occurs when Bandicam is configured to record with the Xvid codec downloaded from the website and the codec is then utilized as an 'External Codec' within Bandicam.

An example of the trails/corruption can be seen in this still/frame from a 'corrupted' video:
and more - example of trails_corruption when recording with  logos version 1.jpg
Example of 'trails' or 'corruption' when importing an Xvid-recorded video into Sony Vegas
and more - example of trails_corruption when recording with logos version 1.jpg (192.19 KiB) Viewed 18244 times
It obviously has something to do with the motion/tracking/estimation of the codec, as the trails follow the vectors within the frames (how things move across the frames). Testing settings, I found that the way to 'fix' it, is to record with Motion Search Precision for the Xvid codec OFF (set to "0"). This seems to be an effective workaround, until Xvid/Sony/Adobe/whoever updates and looks at this issue.

An example of 'Before' and 'After' the fix (changing the setting) can be seen in this short video example I threw together:

If this is happening to you, full instructions on how to change the setting with screenshots can be found at my blog here: ... s-and.html

These are the basic steps:
  • 1) If you are using the Xvid MPEG-4 Codec as your [External] recording codec - click Settings, then select it under the Codec pulldown menu (it is under the -External Codec- choice) and click on the ellipsis "...", click on the Configure button to open the Xvid Configuration window.

    2) Then, under the More section, Quality Preset, click the "more..." button past the pull-down menubar and it will Question you with the choice to Copy the values that cannot be changed to a "User Defined" setting. Clicking "Yes" will copy the Real-time Preset settings to the pull-down selection called "User Defined" and then you can change the preset settings within.

    3) In the Motion Precision category on the first tab ("Motion"), next to Motion Search Precision, click on the pull-down menubar and click on "0 - None", to turn off Motion Searching when recording using the Xvid Codec.
That's it. Sony Vegas and Adobe Premiere should both now be able to import your Xvid format recordings without the 'corruption', no matter what game recording program you are using - but of course, we're all using Bandicam, right? 8-)

Not everyone is experiencing this problem, but I hope that it helps anyone else that is (It seems to only happen if you are using Xvid as an 'External Codec' choice..).

Good luck with it and See you in the games!

Re: Sony Vegas Problem If Using Xvid as an External Codec (F

Posted: Fri Jun 07, 2013 5:54 pm
by Bandicam Company
Hi GameTipsAndMore,

Our recommendation for Xvid codec was "Real-time":

However, we have just changed the recommendation setting:

Thank you very much for your information.

Re: Sony Vegas Problem If Using Xvid as an External Codec (F

Posted: Sat Jun 08, 2013 2:52 am
by GameTipsAndMore Blog
You are most welcome! I am glad to help out with your great program, which has friendly support as well.

Yes, the "Real-Time" preset seemed to use a Motion Search Precision setting of "1 - Very Low", which is good for speed of recording, but would cause this problem with Sony Vegas (if using the downloaded/External Codec Xvid version).

The 'Bandicam Version' of Xvid that is built-in/included with Bandicam does not have this problem when importing recordings made from it into Vegas or Premiere. Great job optimizing the codecs, Bandi!