MrVolpix97
Posts: 30
Joined: Sun Sep 15, 2019 7:14 am

Camera problem when recording together with the game

Sun Jan 23, 2022 9:12 pm

Hi, i have a huge problem, when i rec a game together my camera that is a Sony a6400L connected with Game Capture 4K60 Pro MK.2 by Elgato i got the game smooth 60fps with MagicYUV lossless codec but the camera have lag continuosly, this was not going to happen when i was recording with my old webcam logitech c920 where was max 30fps. The MediaInfo of the camera i get is this: https://pastebin.com/WnrxB8Zj

I have a good pc btw, where the info are:
MOBO: Asus ROG Strix Z370-F Gaming
CPU: Intel Core i9-9900KF
RAM: Corsair VENGEANCE RGB PRO 32GB
GPU: MSI GeForce RTX 3080 Ti Gaming X Trio 12G

So the problem is this: Game is smooth, external device (so the camera) is not.

This happen also with other codecs.

How should i fix this problem?

User avatar
Bandicam Company
Site Admin
Posts: 7303
Joined: Mon Dec 20, 2010 12:19 pm

Re: Camera problem when recording together with the game

Fri Jan 28, 2022 7:22 pm

Hello MrVolpix97,

We would appreciate it if you could give us more information about the issue as below.

1. Are the recorded files also unsmooth when you playback them? Or does the preview window of the camera have lag only during recording?
2. Do you have the same issue when you record only your camera with the Device Recording Mode?

We look forward to your reply.

Thank you.

MrVolpix97
Posts: 30
Joined: Sun Sep 15, 2019 7:14 am

Re: Camera problem when recording together with the game

Mon Jan 31, 2022 1:46 am

Hi and thanks for reply me. I wanna explain u correctly everything:
The game i rec play smooth without problem, the camera that i rec together the game play with low fps, u can check the mediainfo by the link i had send before.
If i rec camera only, i got no lag.
While im recording the game and camera together, the Task Manager show that there is not 100% usage by CPU and GPU, but usually is 50% of CPU and GPU usage depends by the game but even if is at 100% for example with my old pc and my old gtx 1060 3GB i had no lag. But i have to say that before with old pc i was using webcam like camera. So i think the problem is that my actual camera rec 60fps, the game too and maybe Bandicam cant' handle all two things at the same moment recording at 60fps smooth. Maybe Bandicam give prority to the game for smoothness 60 fps and for camera make variable framerate and not stable.

The preview of the camera is smooth when i start to record, then i dont know what happen because i turn off the preview for see the game correctly.


Return to “Bandicam - General Discussion”

Who is online

Users browsing this forum: Google [Bot] and 14 guests